KLA12104
Multiple vulnerabilities in Apache Tomcat

Updated: 05/12/2021
Detect date
?
02/02/2021
Severity
?
Warning
Description

Multiple vulnerabilities were found in Apache Tomcat. Malicious users can exploit these vulnerabilities to execute arbitrary code, obtain sensitive information.

Below is a complete list of vulnerabilities:

  1. A security vulnerability can be exploited remotely via special crafted file to execute arbitrary code.
  2. A security vulnerability can be exploited to obtain sensitive information.
Affected products

Apache Tomcat 8.5.x earlier than 8.5.63
Apache Tomcat 9.x earlier than 9.0.43
Apache Tomcat 10.x earlier than 10.0.2

Solution

Update to the latest version
Tomcat 8.5 Software Downloads
Tomcat 9 Software Downloads
Tomcat 10 Software Downloads

Original advisories

Apache Tomcat 8.5.x vulnerabilities
Apache Tomcat 9.x vulnerabilities
Apache Tomcat 10.x vulnerabilities

Impacts
?
ACE 
[?]

OSI 
[?]
Related products
Apache Tomcat
CVE-IDS
?
CVE-2021-253294.4Warning
CVE-2021-251225.0Critical
Find out the statistics of the vulnerabilities spreading in your region