KLA12083
DoS vulnerabilities in Apache Tomcat

Updated: 02/16/2021
Detect date
?
07/05/2020
Severity
?
Critical
Description

DoS vulnerabilities were found in Apache Tomcat. Malicious users can exploit these vulnerabilities to cause denial of service.

Below is a complete list of vulnerabilities:

  1. DoS vulnerability in h2c direct connection can be exploited to cause denial of service.
  2. DoS vulnerability in WebSocket frame can be exploited to cause denial of service.
Affected products

Apache Tomcat 8.5.x earlier than 8.5.57
Apache Tomcat 9.x earlier than 9.0.37

Solution

Update to the latest version
Tomcat 8.5 Software Downloads
Tomcat 9 Software Downloads

Original advisories

Apache Tomcat 8.5.x vulnerabilities
Apache Tomcat 9.x vulnerabilities

Impacts
?
DoS 
[?]
Related products
Apache Tomcat
CVE-IDS
?
CVE-2020-139345.0Critical
CVE-2020-139355.0Critical