KLA12079
DoS vulnerabilties in Wireshark

Updated: 02/16/2021
Detect date
?
09/23/2020
Severity
?
Warning
Description

DoS vulnerabilities were found in Wireshark. Malicious users can exploit these vulnerabilities to cause denial of service.

Below is a complete list of vulnerabilities:

  1. DoS vulnerability in the BLIP dissector can be exploited via special crafted file to cause denial of service.
  2. DoS vulnerability in the MIME Multipart dissector can be exploited via special crafted file to cause denial of service.
  3. DoS vulnerability in the TCP dissector can be exploited via special crafted file to cause denial of service.
Affected products

Wireshark 2.6.x earlier than 2.6.20
Wireshark 3.0.x earlier than 3.0.14 
Wireshark 3.2.x earlier than 3.2.7

Solution

Update to the latest version
Download Wireshark

Original advisories

wnpa-sec-2020-13 · BLIP dissector crash
wnpa-sec-2020-11 · MIME Multipart dissector crash
wnpa-sec-2020-12 · TCP dissector crash

Impacts
?
DoS 
[?]
Related products
Wireshark
CVE-IDS
?
CVE-2020-258665.0Critical
CVE-2020-258635.0Critical
CVE-2020-258625.0Critical
Find out the statistics of the vulnerabilities spreading in your region