KLA12046
Multiple vulnerabilities in Opera

Updated: 05/27/2021
Detect date
?
01/14/2021
Severity
?
Warning
Description

Multiple vulnerabilities were found in Opera. Malicious users can exploit these vulnerabilities to execute arbitrary code, cause denial of service, bypass security restrictions.

Below is a complete list of vulnerabilities:

  1. Use after free vulnerability in autofill component can be exploited to execute arbitrary code or cause denial service.
  2. Data validation vulnerability in networking component can be exploited to bypass security restrictions.
  3. Use after free vulnerability in media component can be exploited to execute arbitrary code or cause denial service.
  4. Heap buffer overflow vulnerability in audio component can be exploited to cause denial of service.
  5. Use after free vulnerability in safe browsing component can be exploited to execute arbitrary code or cause denial service.
  6. Use after free vulnerability in Blink can be exploited to execute arbitrary code or cause denial service.
  7. Policy enforcement vulnerability in WebUI can be exploited to bypass security restrictions.
  8. Use after free vulnerability in drag and drop component can be exploited to execute arbitrary code or cause denial service.
  9. Heap buffer overflow vulnerability in Skia can be exploited to cause denial of service.
  10. Use after free vulnerability in audio component can be exploited to execute arbitrary code or cause denial service.
  11. Out of bounds write vulnerability in V8 can be exploited to cause denial of service.
  12. Use after free vulnerability in payments component can be exploited to execute arbitrary code or cause denial service.
Affected products

Opera earlier than 73.0.3856.344

Solution

Update to the latest version
Download Opera

Original advisories

Changelog for Opera 73
Stable Channel Update for Desktop

Impacts
?
ACE 
[?]

DoS 
[?]

SB 
[?]
Related products
Opera
CVE-IDS
?
Find out the statistics of the vulnerabilities spreading in your region