KLA12005
Multiple vulnerabilities in PostgreSQL

Updated: 11/16/2020
Detect date
?
11/12/2020
Severity
?
Warning
Description

Multiple vulnerabilities were found in PostgreSQL. Malicious users can exploit these vulnerabilities to execute arbitrary code, obtain sensitive information.

Below is a complete list of vulnerabilities:

  1. A code execution vulnerability in psql session can be exploited to execute arbitrary code.
  2. An information disclosure vulnerability in client applications can be exploited to obtain sensitive information.
  3. A security bypass vulnerability can be exploited to execute arbitrary code.
Affected products

PostgreSQL 9.5 earlier than 9.5.24
PostgreSQL 9.6 earlier than 9.6.20
PostgreSQL 10 earlier than 10.15
PostgreSQL 11 earlier than 11.10
PostgreSQL 12 earlier than 12.5
PostgreSQL 13 earlier than 13.1

Solution

Update to the latest version
Download PostgreSQL

Original advisories

PostgreSQL News

Impacts
?
ACE 
[?]

OSI 
[?]
Related products
PostgreSQL
CVE-IDS
?
Find out the statistics of the vulnerabilities spreading in your region