KLA11919
Multiple vulnerabilities in Mozilla Firefox
Updated: 08/14/2020
Detect date
?
07/28/2020
Severity
?
Warning
Description

Multiple vulnerabilities were found in Mozilla Firefox. Malicious users can exploit these vulnerabilities to obtain sensitive information, bypass security restrictions, cause denial of service, execute arbitrary code, spoof user interface.

Below is a complete list of vulnerabilities:

  1. Overriding file type vulnerability can be exploited to bypass security restrictions and obtain sensitive information.
  2. Security vulnerability can be exploited to bypass security restrictions.
  3. Security vulnerability can be exploited to obtain sensitive information and bypass security restrictions.
  4. Security vulnerability can be exploited to bypass same origin policy.
  5. Type confusion vulnerability can be exploited to cause denial of service.
  6. Memory safety vulnerability can be exploited to execute arbitrary code.
  7. Implementation vulnerability in WebRTC can be exploited to potentially denial of service.
  8. DLL hijacking vulnerability on Windows can be exploited to bypass security restrictions.
  9. Security UI vulnerabiloty in CSS can be exploited to spoff user interface.
  10. Use after free vulnerability in ANGLE component can be exploited to potentially cause denial of service.
Affected products

Mozilla Firefox earlier than 79

Solution

Update to the latest version
Download Firefox

Original advisories

MFSA2020-30

Impacts
?
ACE 
[?]

OSI 
[?]

DoS 
[?]

SB 
[?]

SUI 
[?]
Related products
Mozilla Firefox
CVE-IDS
?
CVE-2020-64636.8High
CVE-2020-65144.3Warning
CVE-2020-156585.0Critical
CVE-2020-156535.0Critical
CVE-2020-156525.0Critical
CVE-2020-156555.0Critical
CVE-2020-156565.0Critical
CVE-2020-156595.0Critical
CVE-2020-156575.0Critical
CVE-2020-156545.0Critical