KLA11861
Multiple vulnerabilities in Microsoft Products (OSS)

Updated: 07/17/2020
Detect date
?
07/14/2020
Severity
?
High
Description

Multiple vulnerabilities were found in Microsoft Products (Open Source Software). Malicious users can exploit these vulnerabilities to cause denial of service, gain privileges.

Below is a complete list of vulnerabilities:

  1. A denial of service vulnerability in Bond can be exploited remotely via specially crafted content to cause denial of service.
  2. An elevation of privilege vulnerability in Visual Studio and Visual Studio Code can be exploited remotely to gain privileges.
Affected products

Microsoft Visual Studio 2017 version 15.9 (includes 15.0 - 15.8)
Microsoft Visual Studio 2019 version 16.0
Azure Storage Explorer
Visual Studio Code
TypeScript
Bond 9.0.1
Microsoft Visual Studio 2019 version 16.6 (includes 16.0 - 16.5)
Microsoft Visual Studio 2019 version 16.4 (includes 16.0 - 16.3)

Solution

Install necessary updates from the KB section, that are listed in your Windows Update (Windows Update usually can be accessed from the Control Panel)

Original advisories

CVE-2020-1469
CVE-2020-1416

Impacts
?
DoS 
[?]

PE 
[?]
Related products
Microsoft Visual Studio
CVE-IDS
?
CVE-2020-14169.3Critical
CVE-2020-14695.0Critical
Microsoft official advisories
Microsoft Security Update Guide
Find out the statistics of the vulnerabilities spreading in your region