KLA11635
Multiple vulnerabilities in Mozilla Thunderbird
Updated: 06/18/2020
Detect date
?
01/10/2020
Severity
?
Critical
Description

Multiple vulnerabilities were found in Mozilla Thunderbird. Malicious users can exploit these vulnerabilities to obtain sensitive information, cause denial of service, execute arbitrary code, perform cross-site scripting attack, bypass security restrictions.

Below is a complete list of vulnerabilities:

  1. Memory corruption vulnerability on Windows can be exploited locally to obtain sensitive information.
  2. Memory corruption vulnerability on Windows can be exploited locally to cause denial of service.
  3. Memory corruption vulnerability can be exploited locally to execute arbitrary code.
  4. Type confusion vulnerability can be exploited remotely to cause denial of service.
  5. CSS sanitization vulnerability can be exploited locally.
  6. Type confusion vulnerability can be exploited locally to execute arbitrary code.
  7. Bypass security vulnerability can be exploited locally to obtain sensitive information.
Exploitation

Malware exists for this vulnerability. Usually such malware is classified as Exploit. More details.

Affected products

Mozilla Thunderbird earlier than 68.4.1

Solution

Update to the latest version
Download Mozilla Thunderbird

Original advisories

mfsa2020-04

Impacts
?
ACE 
[?]

OSI 
[?]

DoS 
[?]

SB 
[?]

XSS/CSS 
[?]
Related products
Mozilla Thunderbird
CVE-IDS
?
CVE-2019-170240.0Unknown
CVE-2019-170210.0Unknown
CVE-2019-170160.0Unknown
CVE-2019-170170.0Unknown
CVE-2019-170220.0Unknown
CVE-2019-170150.0Unknown
CVE-2019-170260.0Unknown