KLA11628
Multiple vulnerabilities in Mozilla Firefox
Updated: 05/22/2020
Detect date
?
01/07/2020
Severity
?
High
Description

Multiple vulnerabilities were found in Mozilla Firefox. Malicious users can exploit these vulnerabilities to execute arbitrary code, cause denial of service, obtain sensitive information, bypass security restrictions, perform cross-site scripting attack.

Below is a complete list of vulnerabilities:

  1. ACE vulnerability on Windows can be exploited locally.
  2. Memory corruption vulnerability can be exploited locally to execute arbitrary code.
  3. Memory corruption vulnerability on Windows can be exploited locally to obtain sensitive information.
  4. Bypass security vulnerability can be exploited locally to obtain sensitive information.
  5. Type confusion vulnerability can be exploited locally to execute arbitrary code.
  6. Bypass security vulnerability can be exploited locally to use lower protocol that TLS 1.3.
  7. CSS sanitization vulnerability can be exploited locally.
  8. Bypass security vulnerability on Windows can be exploited locally to obtain sensitive information.
  9. Memory corruption vulnerability on Windows can be exploited locally to cause denial of service.
Affected products

Mozilla Firefox earlier than 72

Solution

Update to the latest version
Download Mozilla Firefox

Original advisories

mfsa2020-01

Impacts
?
ACE 
[?]

OSI 
[?]

DoS 
[?]

SB 
[?]

XSS/CSS 
[?]
Related products
Mozilla Firefox
CVE-IDS
?
CVE-2019-170190.0Unknown
CVE-2019-170240.0Unknown
CVE-2019-170210.0Unknown
CVE-2019-170160.0Unknown
CVE-2019-170170.0Unknown
CVE-2019-170250.0Unknown
CVE-2019-170230.0Unknown
CVE-2019-170220.0Unknown
CVE-2019-170200.0Unknown
CVE-2019-170180.0Unknown
CVE-2019-170150.0Unknown