KLA11471
Multiple vulnerabilities in Oracle VirtualBox
Updated: 06/18/2020
Detect date
?
04/16/2019
Severity
?
Critical
Description

Multiple vulnerabilities were found in Oracle VirtualBox. Malicious users can exploit these vulnerabilities to bypass security restrictions, obtain sensitive information, cause denial of service.

Below is a complete list of vulnerabilities:

  1. Multiple vulnerabilities in Core component of Oracle VM VirtualBox can be exploited locally to bypass security restrictions.
  2. Vulnerability in Core (curl) component of Oracle Secure Global Desktop can be exploited remotely to obtain sensitive information, bypass security restrictions and cause denial of service.
  3. Vulnerability in Core (OpenSSL) component of Oracle Secure Global Desktop can be exploited remotely to obtain sensitive information.
  4. Vulnerability in Application Server (Apache Tomcat) component of Oracle Secure Global Desktop can be exploited remotely to bypass security restrictions.
Exploitation

The following public exploits exists for this vulnerability:

https://www.exploit-db.com/exploits/46747

Affected products

Oracle VM Virtual Box 5.2.x versions earlier than 5.2.28
Oracle VM Virtual Box 6.0.x versions earlier than 6.0.6

Solution

Update to the latest version

Original advisories

Oracle Critical Patch Update Advisory – April 2019

Impacts
?
OSI 
[?]

DoS 
[?]

SB 
[?]
Related products
Oracle VirtualBox
CVE-IDS
?
CVE-2019-27220.0Unknown
CVE-2019-26960.0Unknown
CVE-2019-26570.0Unknown
CVE-2019-26780.0Unknown
CVE-2019-26560.0Unknown
CVE-2019-25740.0Unknown
CVE-2019-26900.0Unknown
CVE-2019-27030.0Unknown
CVE-2019-26790.0Unknown
CVE-2019-26800.0Unknown
CVE-2019-27230.0Unknown
CVE-2019-27210.0Unknown