KLA11463
Multiple vulnerabilities in Wireshark
Updated: 05/22/2020
Detect date
?
04/08/2019
Severity
?
Critical
Description

Multiple vulnerabilities were found in Wireshark. Malicious users can exploit these vulnerabilities to cause denial of service.

Below is a complete list of vulnerabilities:

  1. Infinite loop vulnerability in GSUP dissector can be exploited remotely via specially designed packet to cause denial of service.
  2. Infinite loop vulnerability in IEEE 802.11 dissector can be exploited remotely via specially designed packet to cause denial of service.
  3. Denial of service vulnerability related to TSDNS dissector can be exploited remotely via specially designed packet.
  4. Infinite loop vulnerability in Rbm dissector can be exploited remotely via specially designed packet to cause denial of service.
Affected products

Wireshark 3.0.x earlier than 3.0.1

Solution

Update to the latest version
Get Wireshark

Original advisories

wnpa-sec-2019-12
wnpa-sec-2019-11
wnpa-sec-2019-16
wnpa-sec-2019-13

Impacts
?
DoS 
[?]
Related products
Wireshark
CVE-IDS
?
CVE-2019-108980.0Unknown
CVE-2019-108970.0Unknown
CVE-2019-109020.0Unknown
CVE-2019-109000.0Unknown