KLA11373
Code execution vulnerability in OpenOffice
Updated: 12/04/2018
CVSS
?
6.8
Detect date
?
11/10/2015
Severity
?
High
Description

Lack of bookmarks restrictions was found in OpenOffice. By exploiting this vulnerability malicious users can cause denial of service or execute arbitrary code. This vulnerability can be exploited remotely via a specially designed DOC file.


Technical details

To exploit this vulnerability attacker can construct DOC file with corrupted table of bookmarks. DOC files can be checked for bookmarks validity by opening via Microsoft products. Check of malicious file could lead to rejection of file as corrupted or extraordinary employment of bookmarks may be observable.

Affected products

OpenOffice versions earlier than 4.1.2

Solution

Update to the latest version
Get OpenOffice

Original advisories

OpenOffice advisory

Impacts
?
ACE 
[?]

DoS 
[?]
Related products
OpenOffice.org
CVE-IDS
?

CVE-2015-5214