KLA11299
Multiple vulnerabilities in Mozilla Thunderbird
Updated: 05/22/2020
Detect date
?
08/06/2018
Severity
?
Critical
Description

Multiple serious vulnerabilities were found in Mozilla Thunderbird. Malicious users can exploit these vulnerabilities to cause denial of service, bypass security restrictions and obtain sensitive information.

Below is a complete list of vulnerabilities:

  1. A buffer overflow vulnerability can be exploited remotely to cause denial of service;
  2. Multiple use-after-free vulnerabilities can be exploited remotely to cause denial of service;
  3. An integer overflow vulnerability in SwizzleData can be exploited remotely to cause denial of service;
  4. An integer overflow vulnerability in SSSE3 scaler can be exploited remotely to cause denial of service;
  5. A type confusion vulnerability can be exploited remotely to cause denial of service;
  6. A CORS bypass vulnerability in NPAPI plugins can be exploited remotely to bypass security restrictions;
  7. Multiple unspecified vulnerabilities can be exploited locally to obtain sensitive information;
  8. An integer overflow vulnerability in Skia scaler can be exploited remotely to cause denial of service.
Affected products

Mozilla Thunderbird earlier than 60

Solution

Update to the latest version
Download Mozilla Thunderbird

Original advisories

Mozilla Foundation Security Advisory 2018-19

Impacts
?
OSI 
[?]

DoS 
[?]

SB 
[?]
Related products
Mozilla Thunderbird
CVE-IDS
?
CVE-2018-123598.8Critical
CVE-2018-123608.8Critical
CVE-2018-123618.8Critical
CVE-2018-123627.5Critical
CVE-2018-123637.5Critical
CVE-2018-123647.5Critical
CVE-2018-123656.1High
CVE-2018-123666.1High
CVE-2018-123676.1High
CVE-2018-123686.1High
CVE-2018-123716.1High
CVE-2018-51567.5Critical
CVE-2018-51878.8Critical
CVE-2018-51888.8Critical