KLA11220
Multiple vulnerabilities in Wireshark
Updated: 12/04/2018
CVSS
?
4.3
Detect date
?
04/03/2018
Severity
?
Warning
Description

Multiple serious vulnerabilities have been found in Wireshark. Malicious users can exploit these vulnerabilities to cause denial of service.

Below is a complete list of vulnerabilities:

  1. A vulnenerability related to MP4 dissector can be exploited remotely via specially designed packet or packet trace file to cause denial of service;
  2. A vulnenerability related to ADB dissector can be exploited remotely via specially designed packet or packet trace file to cause denial of service;
  3. A vulnenerability related to IEEE 802.15.4 dissector can be exploited remotely via specially designed packet or packet trace file to cause denial of service;
  4. A vulnenerability related to NBAP dissector can be exploited remotely via specially designed packet or packet trace file to cause denial of service;
  5. A vulnenerability related to VLAN dissector can be exploited remotely via specially designed packet or packet trace file to cause denial of service;
  6. A vulnenerability related to LWAPP dissector can be exploited remotely via specially designed packet or packet trace file to cause denial of service;
  7. A vulnenerability related to TCP dissector can be exploited remotely via specially designed packet or packet trace file to cause denial of service;
  8. A vulnenerability related to CQL dissector can be exploited remotely via specially designed packet or packet trace file to cause denial of service;
  9. A vulnenerability related to Kerberos dissector can be exploited remotely via specially designed packet or packet trace file to cause denial of service;
  10. A vulnenerability related to TN3270, ISUP, LAPD, SMB2, GIOP, ASN.1, MIME multipart, H.223, and PCP dissectors can be exploited remotely via specially designed packet or packet trace file to cause denial of service;

NB: At this moment VENDOR has just reserved CVE numbers for these vulnerabilities. Information can be changed soon.

Affected products

Wireshark 2.4 versions earlier than 2.4.6
Wireshark 2.2 versions earlier than 2.2.14

Solution

Update to the latest version
Download Wireshark

Original advisories

wnpa-sec-2018-22
wnpa-sec-2018-16
wnpa-sec-2018-17
wnpa-sec-2018-19
wnpa-sec-2018-15
wnpa-sec-2018-21
wnpa-sec-2018-20
wnpa-sec-2018-24
wnpa-sec-2018-18
wnpa-sec-2018-23

Impacts
?
DoS 
[?]
Related products
Wireshark
CVE-IDS
?

CVE-2017-9616