KLA11196
Multiple vulnerabilities in PostgreSQL
Updated: 02/15/2018
CVSS
?
6.7
Detect date
?
02/08/2018
Severity
?
High
Description

Multiple serious vulnerabilities have been found in PostgreSQL. Malicious users can exploit these vulnerabilities to bypass security restrictions and obtain sensitive information.

Below is a complete list of vulnerabilities:

  1. A memory disclosure vulnerability in table partitioning can be exploited remotely to bypass security restrictions via purpose-crafted insert to a partitioned table;
  2. An unspecified vulnerability related to creating files in current working directory can be exploited to obtain sensitive information via reading or modifying file with database passwords.
Affected products

PostgreSQL 9.3 earlier than 9.3.21
PostgreSQL 9.4 earlier than 9.4.16
PostgreSQL 9.5 earlier than 9.5.11
PostgreSQL 9.6 earlier than 9.6.7
PostgreSQL 10 earlier than 10.2

Solution

Update to the latest version
Download PostgreSQL

Original advisories

Security Information

Impacts
?
OSI 
[?]

SB 
[?]
Related products
PostgreSQL
CVE-IDS
?

CVE-2018-1052
CVE-2018-1053