KLA11019
Multiple vulnerabilities in VMware products
Updated: 08/17/2018
CVSS
?
7.2
Detect date
?
05/18/2017
Severity
?
High
Description

Multiple serious vulnerabilities have been found in VMware Workstation Pro and VMware Workstation Player. Malicious users can exploit these vulnerabilities to gain privileges and cause a denial of service.

Below is a complete list of vulnerabilities:

  1. An insecure library loading vulnerability can be exploited remotely via specially designed ALSA sound driver configuration files to gain privileges (get root privileges in a Linux host machine);
  2. A NULL pointer dereference vulnerability in the vstor2 driver can be exploited remotely to gain privileges and cause a denial of service in a Windows host machine.

NB: These vulnerabilities don’t have any public CVSS rating so rating can be changed by the time.

Affected products

VMware Workstation Pro 12.x before 12.5.6 for Windows and Linux
VMware Workstation Player 12.x before 12.5.6 for Windows and Linux

Solution

Update to the latest versions
Download VMware Workstation Pro
Download VMware Workstation Player

Original advisories

VMware Security Advisory

Impacts
?
DoS 
[?]

PE 
[?]
CVE-IDS
?

CVE-2017-4915
CVE-2017-4916