KLA10960
Code execution vulnerabilities in Adobe Flash Player
Updated: 06/17/2019
Detect date
?
02/14/2017
Severity
?
Critical
Description

Multiple serious vulnerabilities have been found in Adobe Flash Player. Malicious users can exploit these vulnerabilities to execute arbitrary code.

Below is a complete list of vulnerabilities:

  1. A type confusion vulnerability related to the MessageChannel class can be exploited remotely to execute arbitrary code;
  2. An integer overflow vulnerability related to Flash Broker COM can be exploited remotely to execute arbitrary code;
  3. Use-after-free vulnerabilities can be exploited remotely to execute arbitrary code;
  4. Heap buffer overflow vulnerabilities can be exploited remotely to execute arbitrary code;
  5. Memory corruption vulnerabilities can be exploited remotely to execute arbitrary code.

Technical details

Vulnerabilities (3) occur in a routine related to player shutdown, in the ActionScript 3 BitmapData class, in Primetime SDK event dispatch or might be related to event handlers.

Vulnerabilities (4) occur in the h264 decoder routine, in the Flash Video (FLV) codec and while parsing an MP4 header.

Vulnerabilities (5) occur while performing garbage collection, in the h264 codec (related to decompression) and in Primetime SDK.
To update Adobe Flash Player ActiveX (detected as Flash.ocx) on Windows 8 and higher, install latest updates from Control Panel

Affected products

Adobe Flash Player versions earlier than 24.0.0.221

Solution

Update to the latest versions
Adobe Flash Player Download Center

Original advisories

Adobe Security Bulletin

Impacts
?
ACE 
[?]
Related products
Adobe Flash Player ActiveX
Adobe Flash Player NPAPI
Adobe Flash Player PPAPI
CVE-IDS
?
CVE-2017-298210.0Critical
CVE-2017-298410.0Critical
CVE-2017-298510.0Critical
CVE-2017-298610.0Critical
CVE-2017-298710.0Critical
CVE-2017-298810.0Critical
CVE-2017-299010.0Critical
CVE-2017-299110.0Critical
CVE-2017-299210.0Critical
CVE-2017-299310.0Critical
CVE-2017-29946.8High
CVE-2017-29956.8High
CVE-2017-299610.0Critical