KLA10920
Multiple vulnerabilities in Microsoft Edge and Internet Explorer
Updated: 01/16/2017
CVSS
?
7.6
Detect date
?
12/13/2016
Severity
?
Critical
Description

Multiple serious vulnerabilities have been found in Microsoft Edge, Microsoft Internet Explorer 9 through 11. Malicious users can exploit these vulnerabilities to execute arbitrary code, make code injections, bypass security restrictions or cause denial of service.

Below is a complete list of vulnerabilities:

  1. A scripting engine memory corruption vulnerability can be exploited remotely via a specially designed web site to execute arbitrary code or cause denial of service;
  2. A browser memory corruption vulnerability can be exploited remotely via a specially designed web site to execute arbitrary code or cause denial of service;
  3. Cross-site scripting vulnerability can be exploited remotely via unspecified vectors to inject arbitrary HTML or web script and obtain sensitive information;
  4. Vulnerability in the Web Workers implementation can be exploited remotely via unspecified vectors to bypass the Same Origin Policy  and obtain sensitive information.
Affected products

Microsoft Edge
Microsoft Internet Explorer versions 9 through 11

Solution

Install necessary updates from the KB section, that are listed in your Windows Update (Windows Update usually can be accessed from the Control Panel)

Original advisories

MS16-145

Impacts
?
CI 
[?]

ACE 
[?]

OSI 
[?]

SB 
[?]
Related products
Microsoft Internet Explorer
Microsoft Edge
CVE-IDS
?

CVE-2016-7206
CVE-2016-7181
CVE-2016-7279
CVE-2016-7280
CVE-2016-7281
CVE-2016-7282
CVE-2016-7286
CVE-2016-7287
CVE-2016-7288
CVE-2016-7296
CVE-2016-7297

Microsoft official advisories
MS16-145
KB list

3204062