KLA10913
Multiple vulnerabilities in Mozilla Firefox ESR
Updated: 12/29/2017
CVSS
?
7.5
Detect date
?
12/13/2016
Severity
?
Critical
Description

Multiple serious vulnerabilities have been found in Mozilla Firefox ESR. Malicious users can exploit these vulnerabilities to bypass security restrictions, obtain sensitive information, execute arbitrary code, possibly cause denial of service, gain priveleges or make code injections.

Below is a complete list of vulnerabilities:

  1. An unknown vulnerability can be exploited remotely via marquee tags to bypass security restrictions and allow inline JavaScript;
  2. Memory corruption while using WebGL functions containing vector constructor with a varying array within libGLES can be exploited remotely and possibly cause denial of service;
  3. Use-after-free vulnerability in Editor while performing manipulations with DOM subtrees can be exploited remotely and possibly cause denial of service;
  4. An unknown vulnerability can be exploited remotely via crafted SVG images and use of data: URLs to bypass security restrictions and obtain sensitive information;
  5. Malicious users can use a JavaScript Map/Set timing attack to find out whether an atom is used in specific contexts by another compartment or zone. This can performed to obtain sensitive information (for example, usernames embedded in JavaScript code);
  6. An error occuring while in EnumerateDocuments while adding/removing files can be exploited remotely and possibly cause denial of service;
  7. Improperly sanitized Data from Pocket Server before execution can result in the possibility of HTML injection and access to Pocket’s messaging API;
  8. Due to improper validation or origin of incoming events received by Pocket extension, malicious users can fire events, inject code and commands;
  9. Memory safety bugs can be exploited to run arbitrary code.

Technical details

Vulnerability (8) does not affect users, who have enabled e10s.

NB: This vulnerability have no public CVSS rating so rating can be changed by the time.

NB: At this moment Mozilla just reserved CVE numbers for these vulnerabilities. Information can be changed soon.

Affected products

Mozilla Firefox ESR  45.5.1

Solution

Update to the latest version
Download Mozilla Firefox ESR

Original advisories

Mozilla Foundation Security Advisory 2016-95

Impacts
?
CI 
[?]

OSI 
[?]

SB 
[?]

PE 
[?]

DoS 
[?]
Related products
Mozilla Firefox ESR
Mozilla Firefox
CVE-IDS
?

CVE-2016-9902
CVE-2016-9901
CVE-2016-9893
CVE-2016-9905
CVE-2016-9904
CVE-2016-9900
CVE-2016-9898
CVE-2016-9897
CVE-2016-9895
CVE-2016-9899