KLA10911
Multiple vulnerabilities in Adobe Flash Player
Updated: 06/17/2019
Detect date
?
12/14/2016
Severity
?
Critical
Description

Multiple serious vulnerabilities have been found in Adobe Flash Player. Malicious users can exploit these vulnerabilities to execute arbitrary code or bypass security restrictions.

Below is a complete list of vulnerabilities:

  1. Use-after-free vulnerabilities can be exploited remotely to execute arbitrary code.
  2. Buffer overflow vulnerabilities can be exploited remotely to execute arbitrary code.
  3. Memory corruption vulnerabilities can be exploited remotely to execute arbitrary code.
  4. An unknown vulnerability can be exploited remotely to bypass security restrictions.

Technical details

To update Adobe Flash Player ActiveX (detected as Flash.ocx) on Windows 8 and higher, install latest updates from Control Panel

Affected products

Adobe Flash Player  23.0.0.207 and earlier 
Adobe Flash Player for Linux versions earlier than 11.2.202.637

Solution

Update to the latest versions
Get Flash Player

Original advisories

Adobe Security Bulletin

Impacts
?
ACE 
[?]

SB 
[?]
Related products
Adobe Flash Player ActiveX
Adobe Flash Player NPAPI
Adobe Flash Player PPAPI
CVE-IDS
?
CVE-2016-788010.0Critical
CVE-2016-788110.0Critical
CVE-2016-78907.5Critical
CVE-2016-789210.0Critical
CVE-2016-786710.0Critical
CVE-2016-786810.0Critical
CVE-2016-786910.0Critical
CVE-2016-787010.0Critical
CVE-2016-787110.0Critical
CVE-2016-787210.0Critical
CVE-2016-787310.0Critical
CVE-2016-787410.0Critical
CVE-2016-787510.0Critical
CVE-2016-787610.0Critical
CVE-2016-787710.0Critical
CVE-2016-787810.0Critical
CVE-2016-787910.0Critical