KLA10680
Code execution vulnerability in Adobe Flash Player
Updated: 06/18/2020
Detect date
?
10/14/2015
Severity
?
Critical
Description

Multiple type confusion vulnerabilities were found in Adobe Flash Player. By exploiting these vulnerabilities malicious users can execute arbitrary code. This vulnerability can be exploited remotely via a specially designed SWF file or other unknown vectors.


Technical details

This vulnerability have been exploited in the wild at October 2015.
To update Adobe Flash Player ActiveX (detected as Flash.ocx) on Windows 8 and higher, install latest updates from Control Panel

Affected products

Adobe Flash Player versions earlier than 19.0.0.226
Adobe Flash Player Extended Support Release versions earlier than 18.0.0.255
Adobe Flash Player for Linux versions earlier than 11.2.202.540

Solution

Update to the latest version
Get Flash Player

Original advisories

Adobe bulletin
Adobe bulletin

Impacts
?
ACE 
[?]
Related products
Adobe Flash Player ActiveX
Adobe Flash Player NPAPI
Adobe Flash Player PPAPI
CVE-IDS
?
CVE-2015-764710.0Critical
CVE-2015-764810.0Critical
CVE-2015-76459.3Critical
Exploitation

The following public exploits exists for this vulnerability:

https://www.exploit-db.com/exploits/38969

https://www.exploit-db.com/exploits/38970

https://www.exploit-db.com/exploits/38490

Malware exists for this vulnerability. Usually such malware is classified as Exploit. More details.