KLA10651
Code injection vulnerability in VLC Media Player
Updated: 06/01/2019
Detect date
?
08/17/2015
Severity
?
Warning
Description

Lack of content restrictions was found in VLC Media Player. By exploiting this vulnerability malicious users can inject arbitrary code. This vulnerability can be exploited remotely via a specially designed URL.


Technical details

There is lack of URL neutralization in error page generator at VLC web interface. Malicious can exploit this vulnerability by adding script block to URL. PoC and some solution workaround you can find at quantumleap advisory listed at original advisories section.

Affected products

VLC Media Player versions earlier than 2.2.0

Solution

Update to the latest version
Get VLC

Original advisories

Quantumleap advisory

Impacts
?
CI 
[?]
CVE-IDS
?
CVE-2014-97434.3Warning