KLA10434
Multiple vulnerabilities in PuTTY
Updated: 03/07/2019
Detect date
?
08/19/2013
Severity
?
High
Description

Multiple serious vulnerabilities have been found in PuTTY. Malicious users can exploit these vulnerabilities to cause denial of service, obtain sensitive information or possibly execute arbitrary code. Below is a complete list of vulnerabilities

  1. An integer overflow can be exploited remotely via a specially designed RSA key;
  2. Improper work with memory can be exploited locally;
  3. Buffer overflow and underflow can be exploited remotely via a specially designed DSA signature;
Affected products

PuTTY versions earlier than 0.62

Solution

Update to latest version

Impacts
?
ACE 
[?]

OSI 
[?]

DoS 
[?]
Related products
PuTTY
CVE-IDS
?