KLA10065
Multiple vulnerabilities in Apache httpd
Updated: 06/18/2020
Detect date
?
07/22/2013
Severity
?
Critical
Description

Multiple serious vulnerabilities have been found in Apache httpd. Malicious users can exploit these vulnerabilities to gain privileges, cause denial of service, execute arbitrary code, obtain sensitive information or bypass security restrictions. Below is a complete list of vulnerabilities

  1. An integer overflow vulnerability can be exploited locally via a specially designed HTTP request & htaccess file;
  2. A stack consumption vulnerability can be exploited via a specially designed fnmatch call;
  3. Vectors related to the scoreboard can be exploited via modifying memory segments;
  4. A nonsecure write vulnerability can be exploited remotely via a specially designed HTTP request;
  5. An improper restriction vulnerability can be exploited remotely via specially designed header & web scripts ;
  6. Vectors related to mod_proxy can be exploited remotely via a specially formed URI;
  7. Vectors related to byterange filter can be exploited remotely via specially formed headers.
Affected products

Apache httpd 2.0 versions 2.0.64 and earlier

Solution

Update to latest version

Original advisories

Apache changelog

Impacts
?
ACE 
[?]

OSI 
[?]

DoS 
[?]

SB 
[?]

PE 
[?]
Related products
Apache HTTP Server
CVE-IDS
?
CVE-2011-31927.8Critical
CVE-2013-18625.1High
CVE-2012-00314.6Warning
CVE-2011-04194.3Warning
CVE-2011-36074.4Warning
CVE-2011-33685.0Critical
CVE-2012-00534.3Warning
Exploitation

The following public exploits exists for this vulnerability:

https://www.exploit-db.com/exploits/17696

https://www.exploit-db.com/exploits/17969