DIESER SERVICE KANN ÜBERSETZUNGEN VON GOOGLE ENTHALTEN. GOOGLE ÜBERNIMMT KEINERLEI VERANTWORTUNG FÜR DIE ÜBERSETZUNGEN. DARUNTER FÄLLT JEGLICHE VERANTWORTUNG IN BEZUG AUF RICHTIGKEIT UND ZUVERLÄSSIGKEIT SOWIE JEGLICHE STILLSCHWEIGENDEN GEWÄHRLEISTUNGEN DER MARKTGÄNGIGKEIT, NICHT-VERLETZUNG VON RECHTEN DRITTER ODER DER EIGNUNG FÜR EINEN BESTIMMTEN ZWECK.

Die Website von Kaspersky Lab wurde für Ihre Bequemlichkeit mithilfe einer Übersetzungssoftware von Google Translate übersetzt. Es wurden angemessene Bemühungen für die Bereitstellung einer akkuraten Übersetzung unternommen. Bitte beachten Sie, dass automatisierte Übersetzungen nicht perfekt sind und menschliche Übersetzer in keinem Fall ersetzen sollen. Übersetzungen werden den Nutzern der Kaspersky-Lab-Website als Service und "wie sie sind" zur Verfügung gestellt. Die Richtigkeit, Zuverlässigkeit oder Korrektheit jeglicher Übersetzungen aus dem Englischen in eine andere Sprache wird weder ausdrücklich noch stillschweigend garantiert. Einige Inhalte (z. B. Bilder, Videos, Flash, usw.) können aufgrund der Einschränkungen der Übersetzungssoftware möglicherweise nicht inhaltsgetreu übersetzt werden.

KLA11014
Mupltiple vulnerabilities in PostgreSQL
Aktualisiert: 03/29/2019
Erkennungsdatum
?
05/11/2017
Schweregrad
?
Alarmierend
Beschreibung

Multiple serious vulnerabilities have been found in PostgreSQL. Malicious users can exploit these vulnerabilities to bypass security restrictions and obtain sensitive information.

Below is a complete list of vulnerabilities:

  1. An incorrect check of user privileges in some selectivity estimation functions can be exploited remotely possibly to bypass security restrictions or obtain sensitive information;
  2. An issue with enforcing a SSL/TLS connection which is done by the PGREQUIRESSL environment variable can be exploited remotely possibly to bypass security restrictions or obtain sensitive information;
  3. An improper implementation of pg_user_mappings access qualifications can be exploited remotely to obtain sensitive information.

Technical details

Vulnerability (1) is related to providing information from pg_static.

NB: These vulnerabilities don’t have any public CVSS ratings so rating can be changed by the time.

Beeinträchtigte Produkte

PostgreSQL 9.2.x before 9.2.21
PostgreSQL 9.3.x before 9.3.17
PostgreSQL 9.4.x before 9.4.12
PostgreSQL 9.5.x before 9.5.7
PostgreSQL 9.6.x before 9.6.3

Lösung

Update to the latest version
Download PostgreSQL

Ursprüngliche Informationshinweise

PostgreSQL Security Update Release

Folgen
?
OSI 
[?]

SB 
[?]
CVE-IDS
?
CVE-2017-74845.0Warning
CVE-2017-74854.3Warning
CVE-2017-74865.0Warning

Link zum Original